Problems with Virtual Hosting

Back to topics list To post a new topic, please log in or register
avatar
1
hansolo666 2016.09.11 15:53
 

Hello,

 I have a problem with the virtual hosting in MT4. After synchronization my EA works only until a new tick arrives, after which it is automatically deactivated.

 My approach is as follows:

 1) I activate the "Auto Trading" Button

 2) I prefer the EA in the chart and activate "Life Trading permit"

 3) I sync everything with the Virtual Host "MQL5 New York 3"

 4) Following is the "Auto Trading" disabled, but the smiley face in the chart's still smiling.

 5) If a new tick, the Smiley no longer smiling. I have a feeling that then deactivated also the EA in the virtual host. Error message goes here on but no one, the EA but no longer works.

 As a workaround I have found the following solution: In a non-trading time making steps 1-4 and close the MT4, while Smiley is still smiling. Then do nothing and one day later open the MT4. He then works! As intended.

A interim login with my phone on the MT4 App disables the EA also, so I have no way of its functionality to monitor.

 

My question: Is there a solution, how can I let the EA running on the virtual host and could observe his activity at the same time on the MT4, without the EA disabled?

avatar
1223
FMIC 2016.09.11 16:04 #
 
hansolo666: I have a problem with the virtual hosting in MT4. After synchronization my EA works only until a new tick arrives, after which it is automatically deactivated ...

Have you analysed the Journal Logs (both the Main and Experts) to see what errors were reported? This should be the very first thing you do in order to track down the source of the problem.


Back to topics list  

To add comments, please log in or register