Install problem

Back to topics list To post a new topic, please log in or register
avatar
1214
ggekko 2016.06.30 19:03
 


Guys, I'm extremely nervous, please help me.

I use Linux. Earlier was able to install MT4 via Wine without any problem.

Since the latest some builds of MT4 it is impossible to install the MT4.

I get this:


It requires I do enter proxy settings. As far as I know, I don't use any proxy.

How this issue can be resolved?

Thank you

avatar
736
honest_knave 2016.06.30 19:56 #
 

You can install it elsewhere (Windows) and then copy the folder over.

Or, you can install with Wine 1.5.16 which apparently avoids the proxy issue

 

avatar
1214
ggekko 2016.06.30 20:25 #
 
honest_knave:

You can install it elsewhere (Windows) and then copy the folder over.

Or, you can install with Wine 1.5.16 which apparently avoids the proxy issue

 

The copy method is already known by me (I did it until now), but it is impossible that doesn't exist better and straight method?!

I've already tried 1.5.16 without success (maybe I did something wrong).

avatar
1216
FMIC 2016.06.30 22:55 #
 
ggekko:

The copy method is already known by me (I did it until now), but it is impossible that doesn't exist better and straight method?!

I've already tried 1.5.16 without success (maybe I did something wrong).

Please remember that this not really a MetaTrader issue, but a problem with Wine. MetaTrader is only guaranteed to work on a Microsoft Windows. I am sure that MetaQuotes try to anticipate some of Wine's peculiar functionally, but in essence, Wine is just a virtual emulation of Windows and can never be 100% the same as the original.

avatar
1214
ggekko 2016.06.30 23:45 #
 
FMIC:

Please remember that this not really a MetaTrader issue, but a problem with Wine. MetaTrader is only guaranteed to work on a Microsoft Windows. I am sure that MetaQuotes try to anticipate some of Wine's peculiar functionally, but in essence, Wine is just a virtual emulation of Windows and can never be 100% the same as the original.

Yes, but earlier there wasn't any problem. Now there is.
avatar
1216
FMIC 2016.07.01 00:29 #
 
ggekko:
Yes, but earlier there wasn't any problem. Now there is.
  • I repeat, this is not a MetaTrader issue, it is a Wine issue. MetaQuotes is under no obligation to make their application "Wine" compatible, because its a "kludge" and MetaQuotes warns of the problems associated with using Wine and I quote:
Note that Wine is not a fully stable application. Thus, some functions in the applications you start under it may work improperly or not work at all.
  • I have never used Wine, but "honest_knave" provided you with a link to a solution, where besides using Wine 1.5.16, you still need to apply extra steps (some extra libraries and updates), as described by some user comments. Did you even try that?
  • Have you perhaps even consulted the Official MetaTrade 4 Wine thread on the matter? There are user comments there about this issue and possible solutions.
avatar
98
alexey_pak 2016.07.01 10:10 #
 
ggekko:

Guys, I'm extremely nervous, please help me.

I use Linux. Earlier was able to install MT4 via Wine without any problem.

Since the latest some builds of MT4 it is impossible to install the MT4.

I get this:

It requires I do enter proxy settings. As far as I know, I don't use any proxy.

How this issue can be resolved?

Thank you

Hi you should download new metatrader 4 installer.
avatar
1214
ggekko 2016.07.01 14:34 #
 
alexey_pak:
Hi you should download new metatrader 4 installer.
Tried, but the problem is the same. It also asks proxy.
avatar
1214
ggekko 2016.07.01 14:38 #
 
FMIC:
  • I repeat, this is not a MetaTrader issue, it is a Wine issue. MetaQuotes is under no obligation to make their application "Wine" compatible, because its a "kludge" and MetaQuotes warns of the problems associated with using Wine and I quote:
Note that Wine is not a fully stable application. Thus, some functionsin the applications you start under it may work improperly or not workat all.
  • I have never used Wine, but "honest_knave" provided you with a link to a solution, where besides using Wine 1.5.16, you still need to apply extra steps (some extra libraries and updates), as described by some user comments. Did you even try that?
  • Have you perhaps even consulted the Official MetaTrade 4 Wine thread on the matter? There are user comments there about this issue and possible solutions.


Of course, I've tried everything written there before but without success.

Wine 1.5.16 is bosh, doesn't work.

There is nothing useful on the "official" link you gave.

Whatever I do, it always DOES ASK proxy.

WHY?!?!?!

This is a shame on Metaquotes. If they unwilling to make a native MT4 for Linux, at least they should make a workaround to resolve this annoying problem!

Currently it is impossible to install a fresh MT4 on Linux!!!


Back to topics list  

To add comments, please log in or register