EX4 Write Error

Back to topics list To post a new topic, please log in or register
fade2trade 2016.06.20 22:03
I am getting an EX4 Write Error on every piece of code I try to compile in the MetaEditor. Based on research via g*** here is what I have done so far, that did not fix my situation:

1. I made sure that I am not affected by the folder location change that came up with 4.00/600 - https://www.mql5.com/en/articles/1388
2. I did uninstall and reinstall the Metatrader 4 from http://www.metatrader4.com/en/download according to that  text: https://forum.mql4.com/61703#977680
3. I ensured to run my checks on the right Metatrader data folder via MetaEditor Menu / File / Open Data Folder
4. I checked permissions of the metatrader data folder -> the user that runs Metatrader has write access to the folders
5. I checked the file attributes -> no folder or file in the metatrader data folder is write protected
6. I installed Metatrader 5 from http://www.metatrader5.com/en/download, created a new expert in there via the menu and tried to compile it
    -> it returned an EX5 Write Error
    -> I ensured that the data folder of MT4 and MT5 are not the same via MetaEditor Menu / File / Open Data Folder
7. I checked through every single menu item and all Config Options that you can reach via MetaEditor Menu/ Tools/ -> did not find any folder path configuration entries or other potentially related switches.

- OS: Windows Vista
- MetaEditor Menu/ Help/ About of the application that I installed as Metatrader 4 returns me Build 5.00 / 1342 (01 Jun 2016)

How do I fix the issue? What kind of further tests do make sense to be run or is there a way to tranform the "EX4 Write error" error message into something more descriptive (root cause)?

The issue came originally up >1 year ago, after I had to update the platform to the next version (version at that time cannot be replicated). At that time I decided to pause my Meta Trader activities due to other projects - the last 'motivation item' for pausing my activities was that EX4 Write Error. However, NOW I would like to produce a series of indicators and experts and that is where I need the Metatrader compile functionality.

I have the german version installed - I translated the menu names by hand - means mismatches in translation do NOT imply errors in processing these actions.

Ovo 2016.06.20 23:15 #
Try to disable the virus protection for a while.
alexey_pak 2016.06.21 10:45 #
Hello please provide more details and write a ticket to the ServiceDesk.
WHRoeder 2016.06.21 14:37 #
fade2trade: MetaEditor Menu/ Help/ About of the application that I installed as Metatrader 4 returns me Build 5.00 / 1342 (01 Jun 2016)

Build 950 is build 1241 22 Dec 2015. Likely Release 971 is totally buggy - looking for a download for release 970, please help (Doerk) - MQL4 forum (or 970)

fade2trade 2016.06.21 19:20 #

@Ovo: it is off - no difference.

@alexey_pak: I assumed this forum is the official way to raise questions to Metaquotes - otherwise I do not get, why the topic list is poluted by topics from a user called MetaQuotes. Do you have any link or hint, where or how I can submit a ticket to the ServiceDesk of MetaQuotes?

@WHRoeder: I read this thread and others and it seems to be impossible to downgrade. Not sure where to go from there. Does this mean, I have to look for another trading automation platform (and learn another programming language)?

fade2trade 2016.06.21 19:40 #
@alexey_pak: ok, I got that. Going from the mql4 forum to the mql5 forum profile and finding the Service Desk menu item took me another 20 minutes. ...still motivated to discover the jungle of access traps... ;)
Back to topics list  

To add comments, please log in or register