Different backtest results with same parameters (including spread etc)

Back to topics list  | 1 2 To post a new topic, please log in or register
avatar
34
paranoyakX 2016.05.09 18:33 #
 
FMIC:

I have never traded Indices but from your description then the TICK_VALUE should be constant since you have a USD deposit/balance.

So, the conclusion that I come to, is that maybe it has nothing to do with the broker or its data but maybe it has to do with the EA code itself. Maybe there are bugs in it that is causing the problem.

If you don't mind showing the code, we can try looking at it. Alternatively, if you have a coder friend or acquaintance that you trust, have them take a look at it and run tests of their own in order to see if they can find the problem.

thank you very much for your answers. I was also a software engineer. I will recheck my code for bugs. I will share my code at the end but first I want it complete. paranoyak_X@hotmail.com is my email, you can send me an email and I will share it with you.
avatar
34
paranoyakX 2016.05.09 18:59 #
 

I am using a code like this:

 

High[iHighest(NULL,0,MODE_HIGH,20,0)] 

 is this can  cause something like that ? because rest of my code is just open order and close order.

avatar
1229
FMIC 2016.05.09 19:28 #
 
paranoyakX:

I am using a code like this:

High[iHighest(NULL,0,MODE_HIGH,20,0)] 

 is this can  cause something like that ? because rest of my code is just open order and close order.

Probably not, but it is a good practice to test the "Bars" to make sure that it can support the "20" bars of history you use in your iHighest() example.

Is the FXT file generated by 3rd Party tool based on external tick data?

If yes, then that can happen and you will have to test the "Bars" variable. If not and the test data is generated by MetaTrader by using broker data, then probably it is not the problem.

I will send you an email if you feel comfortable about me looking at your code.

avatar
34
paranoyakX 2016.05.09 21:03 #
 

Hello FMIC,

 

I do not touch fxt files, I do my test for a few months and now I can do my test since 01.Nov.2015. I just do backtest everyday and not touching fxt files.

avatar
Moderator
3206
angevoyageur 2016.05.09 21:05 #
 
Doerk:
I assume you are somewhere mixing different time functions, TimeLocal instead of TimeCurrent and/or usage of GetTickCount. 

That can't have influence in the backtester. TimeLocal() and TimeCurrent() give the same value.

GetTickCount() could be a possibility, but it would be very strange if used in trading decisions.

avatar
Moderator
3206
angevoyageur 2016.05.09 21:07 #
 
FMIC:

I have never traded Indices but from your description then the TICK_VALUE should be constant since you have a USD deposit/balance.

So, the conclusion that I come to, is that maybe it has nothing to do with the broker or its data but maybe it has to do with the EA code itself. Maybe there are bugs in it that is causing the problem.

If you don't mind showing the code, we can try looking at it. Alternatively, if you have a coder friend or acquaintance that you trust, have them take a look at it and run tests of their own in order to see if they can find the problem.

The probability that the problem comes from code is very low. From some data very high.
avatar
Moderator
3206
angevoyageur 2016.05.09 21:10 #
 
paranoyakX:

Hello FMIC,

 

I do not touch fxt files, I do my test for a few months and now I can do my test since 01.Nov.2015. I just do backtest everyday and not touching fxt files.

Did you try to test and compare being disconnected from the broker ? I read quickly the previous posts and can't see a clear answer (sorry if I missed something).


avatar
69
Tecuciztecatl 2016.05.09 22:10 #
 
paranoyakX:

Hello everyone,

 for a few months, I was trying to do some backtests and I realized something (I also search the forum but other topics are different than my problem): Yesterday I did some backtest, close my laptop etc and today I tried to run one of profitable results but with same parameter that result stopped out today.

 here is the thing:

same parameters

same date range (end date is also fixed like : 01-01-2016 and 30-04-2016)

same spread (I fixed it to 3)

same computer

same metatrader

same broker.

 As I said, it was a profitable result according to yesterdays backtest result but today, it is not! I tried many results and they all have different results today. what could it be ?

 

thanks. 

You did not write: same account.
avatar
1229
FMIC 2016.05.09 22:12 #
 

I have taken a look at the code as well as run several back-tests, and although there are many bugs, none could cause the different back-test results, nor were there any deviations with the tests I ran.

So, as "angevoyageur" predicted, the differences in the tests are not caused by the code but by some other factor unknown to us.

PS! There is just one caveat - the strategy uses Martingale, and so small changes in Market values could cause MAJOR changes in the results. In my case, since I am using 3rd Party Generated FXT and HST files (and disconnected from broker), the results were always consistent.

Back to topics list   | 1 2  

To add comments, please log in or register