Metatrader 4 Command Line Powershell .ini Startup Example

Back to topics list To post a new topic, please log in or register
avatar
59
investguy 2016.03.14 05:23
 

Hi, 

 

I've been unsuccessfully trying to start  from powershell command line the terminal.exe program. The .ini file look like this :

 

; common settings

Login=2089020454

Password=7ze45v3u

EnableNews=false

; experts settings 

ExpertsEnable=true

ExpertsDllImport=true

ExpertsExpImport=true

ExpertsTrades=true

; start strategy tester

TestExpert=SESSIONS-OPT

TestSymbol=EURUSD

TestPeriod=M30

TestModel=0 

TestSpread=20 

TestOptimization=true

TestDateEnable=true

TestFromDate=2010.01.01

TestToDate=2015.01.01

TestShutdownTerminal=true

TestVisualEnable=false

 

 The commands i'm using are:

cmd /c start /min /wait M:\$($folder)\terminal.exe /portable tester\files\$($symbol)\$($ea)_OPT.ini

start /min /wait M:\MT4-0\terminal.exe /portable /config:M:\MT4-0\tester\files\SESSIONS-OPT_OPT.ini

$arguments = " /portable tester\files\$($symbol)\$($ea)_OPT.ini" 

Start-Process -WindowStyle Minimized -Wait -FilePath "M:\$($folder)\terminal.exe $arguments"

Start-Process -FilePath M:\$($folder)\terminal.exe -ArgumentList '/portable', 'M:\$($folder)\tester\files\$($symbol)\$($ea)_OPT.ini' #| Wait-Process

Start-Process -FilePath "M:\MT4-0\terminal.exe" -ArgumentList '/portable', 'M:\MT4-0\tester\files\EURUSD\SESSIONS-OPT_OPT.ini'

 

Any inputs? thanks. 

avatar
59
investguy 2016.03.14 06:18 #
 

I got it going with:

 

cmd /c start /min /wait M:\$($folder)\terminal.exe /portable M:\$($folder)\tester\files\$($symbol)\$($ea)_TEST.ini 

 

and this is the result in the terminal:

 

 2016.03.14 01:16:22.979 '2089020454': previous successful authorization performed from 

2016.03.14 01:16:21.854 '2089020454': login on Tickmill-DemoUK through main IP (ping: 133.51 ms)

2016.03.14 01:16:20.977 Started with configuration file 'M:\MT4-0\tester\files\EURUSD\SESSIONS-OPT_OPT.ini'

2016.03.14 01:16:20.961 Data Folder: M:\MT4-0

22016.03.14 01:16:20.961 Armada Markets build 950 started (Armada Markets Pty Ltd)

 

The content of SESSIONS-OPT_OPT.ini is:

 

; common settings

Login=2089020454

Password=7zexkvu

EnableNews=false

; experts settings

ExpertsEnable=true

ExpertsDllImport=true

ExpertsExpImport=true

ExpertsTrades=true

; start strategy tester

TestExpert=SESSIONS-OPT

TestSymbol=EURUSD

TestPeriod=M30

TestModel=0

TestSpread=20

TestOptimization=true

TestDateEnable=true

TestFromDate=2010.01.01

TestToDate=2015.01.01

TestShutdownTerminal=true

TestVisualEnable=false

 

Why is the terminal not starting the optimization automatically with the setting in the .ini file? 

avatar
59
investguy 2016.03.14 07:47 #
 
Figured out.. the Ini file needs to be converted to ASCII in order to be loaded correctly 
avatar
1110
Ovo 2016.03.14 10:07 #
 
investguy:
Figured out.. the Ini file needs to be converted to ASCII in order to be loaded correctly 
Hopefully you did not expose your genuine account credentials here.
Back to topics list  

To add comments, please log in or register