Why does this initiation fail?

Back to topics list To post a new topic, please log in or register
avatar
228
jollydragon 2015.10.12 17:03
 

 

When my same EA ran EventSetMillisecondTimer(50) within OnInit() on 4 charts, it returns successful on 1 chart  only, wrong code is " Internal error"(translated to the description) on all other 3 charts.

Why did it happen? How to prevent or fix the issue? Thanks.  

avatar
12983
WHRoeder 2015.10.12 18:05 #
 
  1. How should us users know why an internal error happens? It's internal to the terminal.
  2. How should us users be able to fix the issue? It's internal to the terminal and we don't have the code.
  3. This is a user's forum not Metaquotes.
avatar
126
Demos 2015.10.12 18:45 #
 

jollydragon:

 

When my same EA ran EventSetMillisecondTimer(50) within OnInit() on 4 charts, it returns successful on 1 chart  only, wrong code is " Internal error"(translated to the description) on all other 3 charts.

Why did it happen? How to prevent or fix the issue? Thanks.  

 

WHRoeder:
  1. How should us users know why an internal error happens? It's internal to the terminal.
  2. How should us users be able to fix the issue? It's internal to the terminal and we don't have the code.
  3. This is a user's forum not Metaquotes.

 

I agree, more likely it is a bug. As a workaround, for the time-being, you may make some copies of the EA with different names and tell us what happens. 

 

best regards 

Back to topics list  

To add comments, please log in or register