cannot backtest on older build....

Back to topics list To post a new topic, please log in or register
avatar
249
4evermaat 2015.06.29 04:42
 

I was attempting to backtest on older build as usual b697.  I was doing backtests up to yesterday afternoon.  Then I got an error 'old version'  at the connection server.  No big deal, but since trying to launch other terminals, I get an error 4112 whenever the backtest (not live trading) attempts to place trades as part of the backtest.  This not only happened for my EA, but also happens for even the MACD EA sample.

I then reverted back to a newer mt4 terminal (b765) and backtest places trades ok.  hmmmm

I can understand live connectivity would not work....but why can't I at least perform backtests with older mt4? 

Using Birt's TDS or not, I get the same problem of error 4112 when doing backtests with older builds.

avatar
1
jbmartinez 2015.07.16 17:21 #
 
4evermaat:

I was attempting to backtest on older build as usual b697.  I was doing backtests up to yesterday afternoon.  Then I got an error 'old version'  at the connection server.  No big deal, but since trying to launch other terminals, I get an error 4112 whenever the backtest (not live trading) attempts to place trades as part of the backtest.  This not only happened for my EA, but also happens for even the MACD EA sample.

I then reverted back to a newer mt4 terminal (b765) and backtest places trades ok.  hmmmm

I can understand live connectivity would not work....but why can't I at least perform backtests with older mt4? 

Using Birt's TDS or not, I get the same problem of error 4112 when doing backtests with older builds.

Hi!!!

 

How did you solve the problem of 4142?. Any suggestions?

 

Thanks in advance 

avatar
249
4evermaat 2015.08.19 07:03 #
 
jbmartinez:

Hi!!!

 

How did you solve the problem of 4142?. Any suggestions?

 

Thanks in advance 

The error was 4112.  And I just upgraded to a later version of Tick Data Suite which supported builds up to 845.  Then just upgraded mt4 terminal to b765, although I can also test on b840 which is nice for indicator backtesting.


After updating the mt4 build, I had no more errors.  I suppose you could block internet access for all terminals on the computer you wish to do backtests on.  But when one terminal showed 'old version', any terminal launched with any other broker suddenly would not allow live or backtest trading with 4112 error.

Back to topics list  

To add comments, please log in or register