New MetaTrader 4 Platform Build 830: Hotfix

Back to topics list  | 1 2 3 4 To post a new topic, please log in or register
avatar
98
alexey_pak 2015.06.09 10:21 #
 
husar2003:

Since Build 830 (- no problems had since years )

Seroious problem with MT4 on ALL VPS and ALL brokers :

Terminal looses connection, is not able to reconnect automatically or manually.  It shows a couple of xx ms and mostly all n/a. Even if choosing a connection with a valid ping it is not able to connect and does not show an error, it's just doing NOTHING.

Only closing the terminal ans restarting helps.( Other terminals with same broker riunning fine at same time).

It happens randdomly independant of what EA is running on or if heavy traffic/CPU or not.

Say 1 Terminal of 10 crashes daily. It is really a big bug and a danger for operating.

I'm fighting with this since upgrade i cannot monitor all terminals all the day due to normal work :o

The bug ist also on new installations, it is not a update issue it is a version issue.

1 VPS is  MS Windows Server 2003 R2 Service Pack 2

Please write post to the ServiceDesk and provide more details.
avatar
98
alexey_pak 2015.06.09 10:22 #
 
smacznykonsek:


Hi alexey_pak,

1) I'm on win 7 pro 64bit

2) guess what build of terminal if I'm posting on 830 thread :) ..it's 830 build (and this issue is happening since 646 build)

3) Open the platform, make the window NOT maximized on the screen, stretch the window across the two monitors to cover majority of them, unselect Auto Arrange on toolbars (http://screencast.com/t/u2OjkAmr), space toolbars apart from each other on one line of toolbar bar on the main monitor. Close the platform, open platform again, toolbars will shift to the left, one of them will stay anchored to it's position pre-set prior to restart of the platform (the leftmost one usually but this depends) below is the screenshot of my setup, with toolbars spaced apart, and then what happens to them after platform restart, this is the screenshot of two monitor desktop with the right hand side one being the main screen (1920x1200) and the secondary screen on the left hand side (1920x1080 resolution). Note: on the secondary monitor where the resolution is vertically lower the bottom of platform window is outside of the screen - but I've tried - even if it's not problem still exists. Also on the screenshot below you can see that the Standard toolbar (where I have Terminal and Navigator icons) is positioned on the border between left and right monitor, if I shif it to the left monitor completely it will stay anchored but other toolbars will shift towards it, BUT if I position it to be completely on the right monitor (main one) then all the toolbars will shift all the way to the left edge of the platform window (on the left, secondary monitor).. I tried to investigate this issue some time ago and noted that toolbars positions don't get saved in terminal.ini (if I remember right), or they get erased upon platform restart..

Before platform restart: http://screencast.com/t/Q4WYFh6Pir

Platform after restart, toolbars shift to the left: http://screencast.com/t/emC9ZmiixYQ

Hope this helps and really hope this will get fixed some time soon!

Best regards,

Michael Charazka

Can't reproduce your issue. Please write post to the ServiceDesk and step by step guide.
avatar
2
bigmak 2015.06.10 11:27 #
 
I never had problems with metatrader4, if not active any expert advisor also build 830 works fine.
But If you enable expert advisors, I use Volatility factor, it happens that metatrader random disconnects from the server and no longer able to automatically reconnect. The error is connection failed, you must close the program to wait a few minutes and reopen metatrader4 Directory to resume operation.
avatar
20
salab76 2015.06.10 15:36 #
 
when you give the opportunity to remove the graphics platform for viewing on multiple monitors ???
when you put a filter between search tools?
or put them in alphabetical order ???
when you activate the function for forwarding signals TET platform off?
avatar
12985
WHRoeder 2015.06.10 22:00 #
 
salab76:
when you give the opportunity to remove the graphics platform for viewing on multiple monitors ???
when you put a filter between search tools?
or put them in alphabetical order ???
when you activate the function for forwarding signals TET platform off?
This is a user's forum not Metaquotes. We can't do any of that.

avatar
20
salab76 2015.06.11 09:32 #
 
you are right !!!
I was wrong to post it here ...

but I think that if more users are asking the same thing perhaps support gets to work to realize them !!!

I had previously contacted the service desk ... they said they were not in their priority !!!

yet they are very useful ... I do not understand why they do not make ??? !!!
avatar
1
ic1976 2015.06.12 15:19 #
 

MQL4 script we do not call OnDeinit () function. Please someone help.

 

void OnDeinit(const int reason){

Print("3");

Back to topics list   | 1 2 3 4  

To add comments, please log in or register