help needed for SymbolInfoTick

Back to topics list To post a new topic, please log in or register
avatar
2
orsendorsen 2015.05.14 13:23
 

Hi, I'm new to this forum and mql4. I'm working on my first EA project that handles real-time symbol data using

SymbolInfoTick(). So far so good, it works fine on MqlTick.ask and .bid data, but not on .last and .volume, they are always =0.

I'm running on the downloaded MT4 demo account, Win7. Checked with EURUSD and US100 symbols.

What shall I do to get these data as well? They should be available, since I can put them on the chart, at least volume.

 

Any help is appretiated! Thanks, Orsen

 

 

 

avatar
2
orsendorsen 2015.05.14 17:55 #
 

I also realized that the chart and SymbolInfoTick() give slightly different data. On chart I can see such one minute low values which

are lower than SymbolInfoTick() ever returned. I call SymbolInfoTick() inside a loop which uses sleep(10). Shall I use sleep(1) for

higher resolution? 

avatar
Moderator
3206
angevoyageur 2015.05.31 21:38 #
 
orsendorsen:

Hi, I'm new to this forum and mql4. I'm working on my first EA project that handles real-time symbol data using

SymbolInfoTick(). So far so good, it works fine on MqlTick.ask and .bid data, but not on .last and .volume, they are always =0.

I'm running on the downloaded MT4 demo account, Win7. Checked with EURUSD and US100 symbols.

What shall I do to get these data as well? They should be available, since I can put them on the chart, at least volume.

 

Any help is appretiated! Thanks, Orsen

 

 

 

last and volume will always be 0, they are not available for MT4.
Back to topics list  

To add comments, please log in or register