Indicators get "crashed" after a longer period of running MetaTrader 4

Back to topics list To post a new topic, please log in or register
avatar
2
michaeldz 2015.01.14 14:57
 

Hello!
Sometimes, after a longer period of running MetaTrader, many indicators on ALL charts get corrupted in the same moment. See the screenshots.


- Arrows indicators appear in a strange places (from this moment).
- Line indicators changed values.
- Old bufor values were reset.

There is nothing special in the "Journal" tab, the LOG file does not exist? (MT4 started yesterday has it's logs "20150113.log" - nothing special inside, but there is no log for today "20150114.log").

Does anyone know what could be the reason: indicators, MetaTrader, running MT4 too long...? Do You experience something similar? I would be VEEEERY grateful for a tip!

Thank You!

avatar
2017
gooly 2015.01.14 16:29 #
 
I already told this the Service-Desk - no answer no change as of last update :(
avatar
Moderator
3206
angevoyageur 2015.01.14 16:49 #
 
michaeldz:

Hello!
Sometimes, after a longer period of running MetaTrader, many indicators on ALL charts get corrupted in the same moment. See the screenshots.


- Arrows indicators appear in a strange places (from this moment).
- Line indicators changed values.
- Old bufor values were reset.

There is nothing special in the "Journal" tab, the LOG file does not exist? (MT4 started yesterday has it's logs "20150113.log" - nothing special inside, but there is no log for today "20150114.log").

Does anyone know what could be the reason: indicators, MetaTrader, running MT4 too long...? Do You experience something similar? I would be VEEEERY grateful for a tip!

Thank You!

I got some similar problems, and it was always a bug in the indicator. Of course, that doesn't mean it will always be the case.
avatar
2
michaeldz 2015.01.17 00:53 #
 
Thank You for the reply. I also think there is a bug in an indicator. When I removed one "suspicious" indi from the chart, everything works correctly. Unfortunately I do not have the source code to try to track the bug.
avatar
186
YALEWANG 2015.01.19 14:22 #
 

i experience this too ,i  have doubted  MQL  has memory arrrange erro .


avatar
Moderator
3206
angevoyageur 2015.01.19 14:42 #
 
YALEWANG:

i experience this too ,i  have doubted  MQL  has memory arrrange erro .


Check your code.
Back to topics list  

To add comments, please log in or register