global initialization failed!!!!!!!

Back to topics list  | 1 2 3 4 5 6 7 To post a new topic, please log in or register
avatar
1
PlexHFN 2015.09.24 11:47 #
 

i have here the problem ' 2015.09.24 11:34:49.876    BladeProtect EURUSD,M5: global initialization failed '

how can i find the code to show you my issue?


avatar
Moderator
172
alexvd 2015.09.24 15:35 #
 
PlexHFN:

i have here the problem ' 2015.09.24 11:34:49.876    BladeProtect EURUSD,M5: global initialization failed '

how can i find the code to show you my issue?


The problem has already fixed.

Please, remove the downloaded ex4 file from the disk, restart the terminal, go to the Market -> Purchases tab, reinstall the product.

avatar
3
niniu 2016.02.10 17:04 #
 

I am having the same issue "global initialization failed".

Do have multiple PCs for live testing, running with  an old version MT4 Build 670 with out problems. Decided to check for a new version Build 950. Every  MT4 instance runs ~40 charts, and every PC runs on average 28 MT4 instances (depending resources processor and memory).

What I've noticed is that when many MT4 instances are opened (~29 depending how many charts you run per MT4 instance (there is a limit of 32 MT4 instances))  some instruments fails to initialize and i do get this error "global initialization failed". Every time MT4 is restarted : different symbols are not  initialized. The only way I've figured out is to run fewer MT4 instances. In that case there is no such error.  My guess is: this error got some thing to do with memory, when memory is "low" it just fails to initialize. Got quite powerful setup 32GB of memory (~14GB are in use so still lots of free RAM)  and i7-4790K processor.

Back to topics list   | 1 2 3 4 5 6 7  

To add comments, please log in or register