Strategy Tester: "Waiting for Update" ???

Back to topics list To post a new topic, please log in or register
avatar
1
verdelisan 2010.04.05 00:03
 
When I try to use the Strategy Tester it opens with a black screen with "waiting for update"...no update happens and I'm stuck. I'm using MT4 build 225 from Forex.com. If I reload a new version of MT4 it works for a while, then starts the "waiting for update" nonsense. When I test I get loads of "mismatched chart errors"...could there be a relationship?
Any help is mightily appreciated!
 
avatar
81
McKeen 2010.04.05 12:08 #
 
verdelisan:
When I try to use the Strategy Tester it opens with a black screen with "waiting for update"...no update happens and I'm stuck. I'm using MT4 build 225 from Forex.com. If I reload a new version of MT4 it works for a while, then starts the "waiting for update" nonsense. When I test I get loads of "mismatched chart errors"...could there be a relationship?
Any help is mightily appreciated!


You don´t have the history data needed to display a visual chart for the selected period.
Make sure you have downloaded all data for the dates & timeframe(s) you are using first OR that you are connected to internet when starting the tester and you will be ok.

Also if you run Vista or Windows 7 run MT4 + MetaEditor as an administrator or you might encounter trouble with saving downloaded data in you program-folder creating the need for the client to download new data each session.

Also the history data are saved server-wise in your client meaning that if you for example switch from Demo-server1 to Demo-server2 you will have to re-download all data.


/ McKeen

 
avatar
5
NoIdea 2012.12.16 23:16 #
 
McKeen:


You don´t have the history data needed to display a visual chart for the selected period.
Make sure you have downloaded all data for the dates & timeframe(s) you are using first OR that you are connected to internet when starting the tester and you will be ok.

Also if you run Vista or Windows 7 run MT4 + MetaEditor as an administrator or you might encounter trouble with saving downloaded data in you program-folder creating the need for the client to download new data each session.

Also the history data are saved server-wise in your client meaning that if you for example switch from Demo-server1 to Demo-server2 you will have to re-download all data.


/ McKeen


Hello,

I need help too: although I start the program as an administrator, I download the data before running the test, etc. I get Waiting for Update error message on the Stategy tester on Metatrader4. 

It has been happening to me from time to time. Then other times it doesn't happen. Maybe there is some cache that needs to be cleaned out, but I don't know about it.  

Please help!

 

 


 

 
avatar
12983
avatar
1
Gogelpot 2013.07.04 17:44 #
 
WHRoeder:
Don't install in \program files* on Vista/Win7


NoIdea:


Hello,

I need help too: although I start the program as an administrator, I download the data before running the test, etc. I get Waiting for Update error message on the Stategy tester on Metatrader4. 

It has been happening to me from time to time. Then other times it doesn't happen. Maybe there is some cache that needs to be cleaned out, but I don't know about it.  

Please help!


Non of these solve my problem as I also have the same problem. Any more ideas please.


avatar
14167
RaptorUK 2013.07.04 19:29 #
 
Gogelpot:

Non of these solve my problem as I also have the same problem. Any more ideas please.

Where did you get your data from ?

When you open a M1 chart for the Symbol you want to test and scroll back to the date you are trying to test from do you have bars on your chart ?

 

 

Please answer these 2 questions. 

 
avatar
2
theo1996 2015.04.20 20:46 #
 
First of all check all your journals ,comments, experts and see if any of them returns an error if they do its most propably because you put a later date before the Sooner date and when its sending the request to the server it like telling him to fetch  data froma universe where dates are actually decreasing i had the same problem.
Back to topics list  

To add comments, please log in or register