MQL4 - automated forex trading   /  

Forum

Login | Register | Language: ru cn en
Read the Documentation. It is too Informative to be Ignored

unable to complete activitation of demos

Back to topics list To post a new topic, please log in or register
avatar
112
forestmyopia 2012.01.04 06:01
 
Does anyone know of current issues with MT4? I've tried two different brokers and I cannot complete loading an MT4 demo. When I get to the screen that fills up with green bars, the login and password is not given. As I said, this problem shows up with two different brokers.
 
MQL4 Language for Newbies. Custom Indicators (Part 1)
This is the fourth article from the series "MQL4 Languages for Newbies". Today we will learn to write custom indicators. We will get acquainted with the classification of indicator features, will see how these features influence the indicator, will learn about new functions and optimization, and, finally, we will write our own indicators. Moreover, at the end of the article you will find advice on the programming style. If this is the first article "for newbies" that you are reading, perhaps it would be better for you to read the previous ones. Besides, make sure that you have understood properly the previous material, because the given article does not explain the basics.
avatar
40
BillyJoe 2012.01.04 06:07 #
 

Got the same problem, can't open Demo on any Broker, I have tried several it has been going on since the 31 .

I decided open a tread but found your first.

It appears to be that MetaQuotes server do the demo generation for all brokers, because I can log into Demo accounts that I already have a login info but can't create new ones.

forestmyopia:
Does anyone know of current issues with MT4? I've tried two different brokers and I cannot complete loading an MT4 demo. When I get to the screen that fills up with green bars, the login and password is not given. As I said, this problem shows up with two different brokers.

 
avatar
112
forestmyopia 2012.01.04 06:13 #
 
BillyJoe:

Got the same problem, can't open Demo on any Broker, I have tried several it has been going on since the 31 .

I decided open a tread but found your first.

It appears to be that MetaQuotes server do the demo generation for all brokers, because I can log into Demo accounts that I already have a login info but can't create new ones.



Glad for your input. I was beginning to think there was something wrong with my computer, but you have confirmed its just not my system. I was able to use older demo accounts, but I could not create any new ea's. I hope MetaQuotes gets this resolved soon. I contacted my current broker and was told that MetaQuotes pulled the 409 build and that they will not be able to work on the problem until Thursday. Still on holiday time I guess.

 
avatar
89
peterhw1 2012.01.04 12:39 #
 

Yep - me too.

I have several instances of MT4 installed. I originally had problems with some of the update issues and got advice from the forum back in August http://forum.mql4.com/43115.

Simply put my installations were going into an area C:\Program Files (x86)\Alpari...... and should be installed in C:\Program Files\Alpari...... (i.e. NO (86)).

This seemed to work .. but despite me answering YES to - "do you want to allow the following program to access your computer" program name 'MetaTrader Live Update' the updates didn't actually take place.

So I have some installations with BUILD 402 11th May 2011. Whereas a further installed copy is based on BUILD 409 25th October 2011. The more recent build allows me to open a new account whereas the older build DO NOT allow me to open a new (demo) account.

It appears that I (& others) have a problem with the automatic update process. If you have the latest build - i.e. 409 you should be able to open new demo accounts - if you don't have this Build (in my case 402) then you almost certainly will not be able to open new accounts. The obvious short term solution is to create a new instance / installation of Meta-Trader (using a latest download - possibly depends on broker).

I have raised the question with Alpari UK and may get some additional information.

 
avatar
10044
avatar
89
peterhw1 2012.01.05 12:26 #
 

Not exactly sure what you mean and don't appear to have updates working - what ever my installation process.

when you refer to "\program file* on Vista/Win7"

  1. Do you mean this is correct ? --------- C:\Program Files\Alpari UK_909\....all files & folders installed here
  2. This would be incorrect ? ---------------C:\Program Files (x86)\MetaTrader_Accounts\Alpari UK_909\....all files & folders installed here (i.e. all MetaTrader accounts in one folder)
  3. This would be correct or in correct ---- C:\Program Files\MetaTrader_Accounts\Alpari UK_909\....all files & folders installed here (i.e. all MetaTrader accounts in one folder)


 
avatar
14179
RaptorUK 2012.01.05 13:12 #
 

1,2 & 3 are all incorrect . . . use something like C:\MT4Installs\etc

The problem with ProgramFiles directories is a UAC one . . .

 
avatar
89
peterhw1 2012.01.05 15:42 #
 

I have tried as per your suggestion above and created a new installation in C:\MetaTrader_Installations\Alpari_801\ ....all files & folders installed in this folder.

I can create a new demo account as I would expect (sort of where this thread started)

When I start the program (click the Alpari UK Icon) I don't see any reference to the MetaTrader 4 Live Update program requesting to make changes (this is - I assume - part of the UAC - which I have now by passed).

Equally I don't see any references to BUILD number etc - i.e. no suggestion that it is checking to see if updates are available (Which I wouldn't expect as I have BUILD 409 - Alpari UK's latest).

Is this correct?

Is it checking for updates and because NON are available it doesn't display any information?

Or

Is the system failing to check for updates and will fail to detect when new updates are available?

 
avatar
14179
RaptorUK 2012.01.05 17:05 #
 
peterhw1:


Is it checking for updates and because NON are available it doesn't display any information?

I don't know this for a fact . . but my assumption is that this is correct.
avatar
4
Penna111 2012.09.29 16:45 #
 

I have always installed any MT4 programs in another folder and never had any problems. All of a sudden on any install of MT4, I cannot activate a Demo. This only seems to be on a Windows 7 computer though. To open a demo I install the MT4 platform on a 32 bit Vista computer, generate the demo account and then plug it in on my Windows 7 computer. The problem appears to have happened between, june 2012 and September 2012. I cannot pinpoint if it is a Windows 7 issue or a Win7-MT4 issue. I am running the latest build 438 on FXDD. Anybody else having a problem activating a Demo in Windows 7.

 
Back to topics list  

To add comments, please log in or register